Username:     
Password:     
             

Forum

# 1   2014-05-29 06:15:56 Open4/EvoPrimer hardware questions

zp
New member
Registered: 2013-11-21
Posts: 6

Open4/EvoPrimer hardware questions

Hello, KeoLabs MCU team!
just received my Open4 hardware as a contest prize, thank you!

Some questions about Open4/EvoPrimer hardware to go.

1). Is the LCD revision in Open4 identical to EvoPrimer? With the same programmed STM32F429 daughterboard the picture quality is quite different, EvoPrimer has a bright and vivid picture while Open4 screen seems to be pale and colors aren't bright and dynamic range is small ( sometimes a color saturation is observed). May be it requires a different gamma correction?  I don't think it is a normal deviation.

But Open4 has a better SD card holder. My EvoPrimer requires several attempts to insert card in. And that can not be managed by nail, in Open4 it is very easy. 

2).  What exactly these registers (defined in CircleOS IL9325.h) 

/* Registers not depicted on the datasheet :-( */
#define ILI9325_TIMING_CTRL_1       0xE3  /* Timing control. */
#define ILI9325_TIMING_CTRL_2       0xE7  /* Timing control. */
#define ILI9325_TIMING_CTRL_3       0xEF  /* Timing control. */     

are for? What kind of timings are controlled by them?


3). You defined in CircleOS IL9325.h:

#define ILI9325_START_OSC           0x00  /* Start oscillation, WO.*/

and then use it (in lcd_spe_IL9325.c) like

LCD_Write_Reg( ILI9325_START_OSC, 0x0001 );         // Start oscillator

But the Reg Nr.0 is a Read Only with ID info. Or it is an undocumented trick?
In any case these lines may be skipped.

4). How does a STA529 Reg. Nr 1, flag 0x40 MUTE_ON_INVALID work? If enable it always mutes a most of sound. Does it mean the bad initialization? I see the CircleOS is skipping this flag as well.

5). The STA529 Reg. Nr 0x20 with FFX configuration different to FFX audio frequency range normal   (fs = 32 to 48 kHz)  leads to distorted sound irrelevant to the real Fs. Why? Btw in a audioplayer I can't get it working in a 96KHz stereo mode (just for fun) but it works fine with a Fs = 88KHz.

Is anywhere some more techical note about this STA529 besides the datasheet?

Thank you.

Offline

 

# 2   2014-06-02 08:06:49 Open4/EvoPrimer hardware questions

zp
New member
Registered: 2013-11-21
Posts: 6

Re: Open4/EvoPrimer hardware questions

The problem with a 96KHz audio playback resolved, but all five questions still are actual. Due to my ZP Video Player is announced by KEOLABS as a "media player" I just updated the program with a WAVE player with an INFO tag display capability.

Offline

 

# 3   2014-06-03 12:38:23 Open4/EvoPrimer hardware questions

yrt
Administrator
From: Grenoble-France
Registered: 2008-06-11
Posts: 520
Website

Re: Open4/EvoPrimer hardware questions

Hi Zp,

Some answers to your questions:

1: the hardware and the software are identical for EvoPrimer and Open4. Just the name and the colour case changes ! But it can be exist some quality dispersion between several exemplary.

2, 3 : some registers are not documented, and the initialization code was provided by the LCD manufacturer.

4, 5 : The flag MUTE_ON_INVALID is supposed to mute the sound if the configuration is not correct. The documentation is very poor, we got some help from ST engineers, but it was not simple to implement. No more documentation exists, only evaluation boards and corresponding software. We just implemented the minimum for CircleOS.
But take a look at internet, this codec has been used in some boards under Linux.

Offline

 

Board footer